SSL Einrichtungsassistent läuft nicht durch

Hallo Community,
Zuerst einmal Gratulation zu dem guten Projekt.
ich habe eine Erstinstallation auf einem Debian 11 x64 Server durchgeführt und bin jetzt bei der Einrichtung.
Dabei sind mir verschiedene Probleme aufgefallen, die eventuell zusammenhängen.
1.) wenn ich im Portal den SSL Einrichtungsassistent starte, kommt die Meldung „Voraussetzungen werden überprüft“, im Hintergrund sehe ich „Port 80 ist blockiert durch einen anderen Dienst“ - dann friert der Assistent ein.
2.) ich kann in den Grundeinstellungen keine Parameter mehr verändern - initial ging das mal
Wenn ich etwas ändere und auf Speichern klicke, sind die alten Einstellungen zurück.
3.) Habe versucht, einen Mitglieder - Import durchzuführen - ich wähle eine Excel Datei aus (Beispiel aus der Doku) und klicke auf „Schritt 2“, jetzt erscheint eine Fehlermeldung „502 Bad Gateway - openresty“
image
4.) das goaccess-npm-dashboard auf port 7880 läuft zwar, zeigt aber über all 0

Ich habe zwar etwas Erfahrung mit Linux Systemen aller Art, konnte hier aber nichts genaueres finden.

Könnt ihr mir hier ein paar Ratschläge geben?

Danke aus Ottensoos

Frank

Hallo das mit dem ändern der Grundeinstellung wurde hier in einem Beitrag schon mal erklärt, schau bitte mal im Ordner Store dort die Datenbank Dateien schreib recht geben, dann sollte es wieder klappen.

Das mit dem Assistent habe ich auch das Problem, habe das dann aber über die Konsole direkt gemacht wie in der Doku beschrieben.

Zu der letzten Frage kann ich dir leider nichts sagen.

Grüße Kirsche

Hallo Kirsche,

hatte gerade ein sehr produktives Telefonat :slight_smile:
meine Probleme lagen an dem File Watching des pm2 Prozesses.
Dadurch wurde meine Alarmiator Instanz immer wieder neu gestartet
„pm2 status“ zeigte watching=enabled
„pm2 stop 0 --watch“ stellt watching auf disabled
„pm2 start 0“ startet die Instanz danach wieder.

Jetzt sind die Probleme gelöst - Danke an den guten Support

Gruß,

Frank

1 „Gefällt mir“

Hallo zusammen,

noch ein kurzer Hinweis:

Dem SSL-Wizard werden wir in einer der kommenden Versionen komplett entfernen. Wir haben uns dazu entschlossen, einen Reverse Proxy zu nutzen. Das hat mehrere Vorteile:

  1. Die SSL-Zertifikate werden automatisch erstellt und erneuert. Der Admin muss sich nicht mehr darum kümmern
  2. Aus dem Internet müssen keine unterschiedlichen Ports mehr genutzt und über ein Port-Forwarding konfiguriert werden. Gerade in öffentlichen WLANs ist es gängige Praxis, dass eingebuchte Smartphones nur über die Ports 80 und 443 (SSL) kommunizieren dürfen.

Die Installation des Reverse Proxy (NGINX) ist im Handbuch bereits beschrieben und auch schon vielfach mit ALARMiator stabil im Einsatz.

Bei Fragen zur Einrichtung sowie Umstellung auf NGINX gerne hier im Forum in einem eigenen Topic stellen.

Grüße

Boxson

1 „Gefällt mir“

Hallo,

bei der Installationsanleitung des SSL in der Dokumentation komme ich ab dem Befehl:
docker volume create portainer_data
nicht mehr weiter. Hier erhalte ich die Meldung:
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post „http://%2Fvar%2Frun%2Fdocker.sock/v1.24/volumes/create“: dial unix /var/run/docker.sock: connect: permission denied"

gehe ich dann einfwach zum nächsten Befehl bekomme ich als Rückmeldung:
docker: Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post „http://%2Fvar%2Frun%2Fdocker.sock/v1.24/containers/create?name=portainer“: dial unix /var/run/docker.sock: connect: permission denied.
See ‚docker run --help‘.

Was habe ich hier falsch gemacht?

Viele Grüße
Michael

Hallo Michael,

hast du den Raspberry oder das System mal neu gestartet? Ich glaube mich zu erinnern, dass ich beim ersten Mal ebenfalls das Problem hatte und da Docker aus irgendeinem Grund nicht gelaufen ist und ich einmal neustarten musste und danach funktioniert hat.

Bei weiteren Installationsversuchen hatte ich jedoch keine Probleme bzw. konnte es nicht reproduzieren.

Probier das nochmal und wenn nicht gerne nochmal melden.

Schöne Grüße
Stefan