Einrichtung auf V Server / Certificate / Wallboard installation

Hallo zusammen,

erstmal großes Lob was in kurzer Zeit im Ehrenamt geschaffen wurde.

Momentan geht es mir um eine „Testumgebung“ so das sich die Wehr mit der digitalen Welt vertraut machen kann / abwägen kann ob es eine Verbesserung zu Excel Listen ist :slight_smile:

Mein Gedanke war dazu einen kleinen V Server mit Ubuntu (bei 1und1) anzumieten, mit einem Euro im Monat ist das eigentlich unschlagbar. (Ein Core / 0,5 GB RAM / 10GB SSD)

Die Installation hat grundsätzlich funktioniert und er ist zumindest per WEB (:5000) erreichbar.

Jetzt die Frage an die erfahrenen Anwender, welche Probleme entstehen wenn der Server nicht vor Ort ist. → Vor Ort ist wegen fehlendem Internet im Gerätehaus sowieso schwierig. Kann jemand einschätzen ob die „Hardware“ soweit ausreicht, verwaltet sollen ca 50 Mitglieder werden.

Kann es sein das SSL Verbindung einrichten – ALARMiator – Handbuch nicht mehr die aktuellen Pfade enthält?

Nach abarbeiten des Befehele ist der Port 5010 nicht mehr offen.
Bei force renewal gibt es bei beiden Hooks die Fehlermeldung das /alarmiator/git/alarmiator-server/… nicht gefunden wurde. → einfach anpassen ?!?

Wallboard: nach aufrufen eines Wallboards erscheint im Browser : Error: ENOENT: no such file or directory, stat ‚/home/alarmiator/alarmiatorserver/clients/wallboard_app/client/dist/client/index.html‘
bei npm install wirft er folgendes aus:

Vielen dank schon mal für Hilfe und kameradschaftliche Grüße

Hallo anta, willkommen in der Community,

Der Betrieb auf einem VServer ist überhaupt kein Problem. Auch solltest Du keine Probleme mit der Leistung bekommen. Ein normaler Raspberry Pi 4 dümpelt im Normalbetrieb so bei 1-2 % Prozessorauslastung vor sich hin. Im Alarmfall, wenn viele Anwender den Status melden etc. kann das schon mal leicht ansteigen, aber Dein VServer sollte das locker abkönnen.

Wegen der SSL-Einrichtung schaue ich mir das heute Abend auch mal an, aber da kann @Patrick sicher besser helfen (er hat den Teil im Projekt erarbeitet).

Die Fehlermeldung bei npm install für das Wallboard schauen wir uns auch an. Dazu kann sicher @Semurak was sagen. Du kannst uns das npm - Log (Siehe vorletzte Zeile Deines Screenshot) mal an support@alarmiator.de schicken, da sollte mehr drin stehen zu dem Problem.

Grüße

Bezüglich Fehlermeldung: Das Wallboard ist mit Angular realisiert und wird beim npm install gebaut. Dies schlug bei dir fehl und deshalb exisitiert diese File nicht.

Ich würde an deiner Stelle einfach nochmal npm install aufrufen, evtl. läuft es dann durch und sollte auch erreicht werden.

Zu Beachten ist noch… ich wurde darauf hingewiesen, dass das Wallboard aktuell nicht mit SSL funktioniert, scheinbar muss man da zusätzlich noch etwas bei SocketIO machen :frowning: (evtl. auf Secure umstellen etc.) Ich bin aber noch nicht dazugekommen mir das genauer anzuschauen.

Hallo Anta, ich glaube das ist ein Fehler in der Doku. Kannst du es Mal mit den angepassten Pfaden versuchen und die Links noch Mal neu erzeugen?

Vielen Dank für die schnelle Antwort.
Ein erneutes lauf von npm brachte leider keine Besserung. Das Verzeichniss des Logfiles (/.npm/…) habe ich nicht oder kann es nicht sehen. Weder in Putty noch in WinSCP.
Der weitere Konsolentext sieht so aus:

Bin mir nun nicht ganz Sicher ob hier der Arbeitsspeicher der VM ausgeschöpft war. (im Log waren aber nicht mehr als 75% ausgelastet)

Auch Dir danke für die fixe Antwort.
Ich habe die Falschen Hooks rausgenommen und folgende gesetzt:
sudo sh -c ‚printf „#!/bin/sh\npm2 stop /home/alarmiator/alarmiator_pm2.yml\n“ > /etc/letsencrypt/renewal-hooks/pre/alarmiator_server.sh‘

sudo sh -c ‚printf „#!/bin/sh\npm2 start /home/alarmiator/alarmiator_pm2.yml\n“ > /etc/letsencrypt/renewal-hooks/post/alarmiator_server.sh‘

Certbot lief dann als SUDO erfolgreich durch.

Muss man dann in der WEB GUI noch etwas anpassen? Momentan sind in den Grundeinstellungen http und https aktiviert und im Rest API plugin Pugin aktiv: ja / Port http:5010 / Port https: 5433/ beide aktiviert mit ja

mit netstat -a sind aber nur der port 5000 und 5020 auf listen:

das ist seit dem ersten Cerbot installationsversuch so und auch nach einem reboot geblieben :frowning:

Ja könnte daran liegen, ich guck mir mal an ob man da was machen kann. Evtl. ein Limit setzen kann oder ob man das bauen rausnimmt und das Wallboard so ausliefert…

Ich mache mir mal Gedanken und melde mich.

Hi Anta, evtl musst du die Port die du noch nicht siehst noch in der Firewall frei geben.
Das Programm im Terminal müsste ufw heißen.

Hallo,
das „komische“ ist das der Port 5010 vor der Certbot installation lief und auch einen Port im Netstat ausgewiesen hatte.

Der Linux Firewall ist mit sudo ufw enable auf alles reinlassen gestellt, auf VM (Router) sind die Ports geöffnet.

Scheinbar scheint bei meiner INstallation irgendwas ganz im argen zu sein.
Wenn ich versuche in Admin ->Grundeinstellungen → Datenschutzeinstellung auf nur http zu stellen springt es nach dem Speicher wieder zu http und https zurück.

Wenn ich versuche unter Stammdaten → Benutzter → Berechtigungsgruppen zu ändern sind nach dem Speichern alle Gruppen deaktiviert.

Das ging vor 2 Tagen beides noch, kann dies eine Berechtigungsproblem im Filesys sein?

Macht es Sinn ein debian statt ubuntu zu verwenden?

Hi Anta,

da Ubuntu auf Debian basiert, wird es denke ich keinen Unterschied machen. Auch raspian nutzt als Basis Debian.

Aber irgendwie kommt mir das bekannt vor.
Das Problem hatte ich auch Mal, könnte es aber nicht mehr reproduzieren.
Kannst du Mal schauen, ob du auf die coredatabase.db im Store-Ordner schreiberechte hast mit dem User der den alarmiator betreibt?

Was du auch versuchen kannst ist die coredatabase.db zu kopieren, das Original zu löschen und dann die Kopie zum Original umbenennen. Das hatte es bei mir damals behoben.

Hallo Anta,
falls es Dir noch hilft.
Ich hatte auch das Problem, dass ich bei den Grundeinstellungen nichts mehr verstellen konnte.
Das war ein Problem mit den Symlinks der Zertifikatsdateien bei den Plugins.
Die waren zwar korrekt, aber in dem Verzeichnis war eine Zertifikatsdatei mit gleichem Namen als versteckte Datei vorhanden. Dadurch hat der Symlink nicht mehr funktioniert.
Keine Ahnung wie das passiert ist.

In der Logdatei
/home/meinuser/.pm2/pm2.log

habe ich diesen Fehler gefunden
PM2 error: Error: EACCES: permission denied, watch ‚/home/meinuser/alarmiatorserver/plugins/inbound/api/certificates/privkey.pem‘

Gruss
Jürgen

1 „Gefällt mir“